Jump to content
ADI Forums

Search the Community

Showing results for tags 'poor fermentation'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Terms & Forum Business
    • Terms of Service for ADI Forum Users
    • Forum Business
  • Welcome, ADI News & General
    • Welcome & Introduce Yourself
    • ADI News & Events
    • Beginners
    • General Discussion
    • Speakeasy
  • Producing Product
    • Equipment
    • Packaging
    • Technique
    • Safety
    • Slow Distillation
  • Spirit Specific
    • Vodka
    • Whiskey
    • Gin
    • Rum
    • Absinthe (and other herbals)
    • Brandy
    • Distilled Spirit Specialty
  • Selling Your Product
    • Sales & Marketing
    • Distribution
    • Distillery Tasting Room
  • Government & Guilds
    • Federal Gov't
    • State
    • Local Issues
    • State Distillers Guilds
    • Canada
  • Marketplace
    • For Sale - Peer to Peer
    • For Sale by Vendors
    • Wanted To Buy
    • Marketplace Archive
  • Career
    • Help Wanted
    • Job Wanted
    • Business Opportunities

Calendars

  • Community Calendar

Categories

There are no results to display.

Blogs

  • Scott @ Twenty2Vodka's HighProofSpirit Infusing Blog
  • emutch's Blog
  • mitchabate's Blog
  • EZdrinking
  • Self Distribution
  • Luwest's Blog
  • Black Water Barrels

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Categories

  • New Features
  • Other

Found 1 result

  1. Fermentation stops @ 50%

    Hey guys, I recently started having a string of fermentations stop at about 5% instead of the typical 10%. I've spent a week racking my brain for the cause and can't come to any conclusions. Any ideas or thoughts? Below are more details about the fermentations and attached is our latest water quality report. I appreciate any advice or suggestions. Details (2) 650 gallon fermentations with only 5%abv. I assumed it was something competing with the yeast so I completely tore down and cleaned/sanitized the fermenters...then mashed 2 more 650 gallon batches with the same result. The grain is from the same supplier we've used for years and looks, smells, and tastes the same prior to mashing-Grain is also milled off-site to a fine powder Mashing temps were typical and conversion was on par with an OG of 1.068 The same yeast we've used for years was pitched at the recommended temp and the fermentation looked normal for days 1 and 2. After day 2 activity dropped off drastically and i left it for another 3 days (total of 6 days). When checking the abv the final gravity was 1.038 For 1 batch I pitched additional yeast after day 3 and got a little more activity but negligible difference in abv. 1,200lbs of grain for 650 gallons of mash. grain bills used were a wheat/rye and an all corn recipe. Both with the same result Fermentation temperatures were in the acceptable ranges for the first 4 days. Fermentation smells and taste the same for the first 2 days then the flavor/scent never fully develops. Any help at this point would be appreciated as we're running at 50% efficiency....not the most enjoyable. Thanks Jon. 711316.pdf
×