Jump to content

Dave H

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Dave H

  • Rank
    Contributor

Profile Information

  • Gender
    Male
  • Location
    St. Louis, MO
  • Interests
    beer, bourbon, cars, and guitars!

Recent Profile Visitors

47 profile views
  1. So I pretty much called this one a wash... But I know what I did wrong now... I hate when people post issues and never follow up so I will follow up. I am certain that I did not mash correctly. I'm actually pretty sure that I mashed at too high of a temp. I think it may have been over 160F most of the time and that is hot enough to denature (I think that's the term) the amylase enzymes. I was told they work best from 152F-158F. So I think with THIS batch I only had a little bit of conversion. That would explain why SG only dropped a little bit. So I started a new batch. I waited until temp was 156F before adding malt and amylase enzymes... mashed for more than long enough (over 90 minutes for sure... closer to 2 hours) I checked it with an iodine test (which was tricky because if you swirl it into the mash it does turn blue but when it rests on top it stays an amber color). Then I pitched nutrient and yeast at 90F. Within 2 hours she was bubbling every 2 seconds or so. Within 12 hours my airlock is going nuts. It looks like a rolling boil in there! Thanks for your help, everyone!
  2. @Hypnopooper what were the results of this? How did the ferment turn out? Did you distill it? Age it? I have the same thing going on and I am curious.
  3. @Tom Lenerz this thread has got me thinking the same thing... but I have heard of plenty of people who let it sit overnight. Am I just keeping it too hot? Would you recommend I use a wort chiller and drop the temp straight to 90 after mashing and go ahead and pitch with rehydrated yeast? (I'm going to always rehydrate now). And now the problem I have is that I just did the same thing again last night. Is there anything I can do to remedy THIS batch? I know I should have waited for the next batch until I figured out what I was doing wrong but too late now haha. I figured it was just the amylase enzyme and aerating that was the issue. Thanks.
  4. @Roger that link just took me to the home distiller forum's main page, not any specific post... unless you're just saying I should post this there? FYI I post here because I also do commercial distilling, this is a side project.
  5. @Silk City Distillers what should I do differently? What did I do wrong? I started a new batch last night. Same mash bill but this time I added 1/2 tsp of amylase enzyme after I got the rye and malt mixed in. I cooked the corn for 60 minutes @ 167F-158F... then I added rye and malt @ 158F... mashed for 90 minutes... lowest temp was 148F and the highest was 152F. Now I am letting it rest until it reaches 90F so I can pitch. It's at about 120F right now. The only thing I can think of is that a) maybe I should have added amylase last time and/or b) maybe I didn't aerate it enough when i pitched the yeast.
  6. @RedFalcon I mashed at 158F. Not sure what the temp was when completed but I am sure it was more than 150F. And I didn’t test ph at the time but it is currently 3.50. I feel like it’s a bit low but it has been sitting for 10 days now
  7. @Hudson bay distillers Tim, I placed a grain bag in the bucket before adding the mash... so to take gravity I just pull from the other side of the grain bag. No solids.
  8. @RedFalcon I’ve got those numbers written down at home. I’ll reply soon with that info. @Hudson bay distillers grain in
  9. Hey guys, I want to introduce myself and also piggyback on the last post from @Naked Spirits Distillery. I am a newbie craft distiller and assistant distiller for Naked Spirits in St Louis, MO. I am excited to embark on this journey and extremely grateful to the guys that are starting NS. I have been doing self study on my own for the past year but never pulled the trigger on anything until I met these guys. I was ecstatic to be allowed to intern for them and together we have been learning, experimenting, growing, and more than anything cleaning up after ourselves haha! I recently started my own first batch of whiskey which I just posted about in the whiskey section because I am having issues. So feel free to go there and comment. My background: I am a Navy vet, worked as a nuclear plant operator for 9 years onboard the USS George H W Bush. I then separated from the Navy and went on to work as a maintenance planning specialist for Plant Vogtle in Georgia. And now I am back home in STL working as a Distribution System Supervisor for Ameren MO. Other than that, I hope to grow and learn as a craft distiller. I've even been considering attending Moonshine University's 6 day class. I am ambitious and want to learn this amazing trade! I look forward to hearing from all of you! Thanks for allowing me to join and learn from some of the greatest minds in the industry!
  10. I am a newbie so bear with me... I have started a 5G whiskey mash, 77% flaked corn, 10% distillers malt, 13% flaked rye. I used a small bullet blender to mill the malt. I mashed in a 6.5 gallon kettle for the appropriate times (corn for 60 minutes, then malt and rye for 90 min)... let rest overnight. the next day I pitched 10g of nutrient and 20g of yeast at about 92 degrees (I did not rehydrate the yeast). I left the mash ON the grain. I stirred for quite a while, hopefully enough to agitate and aerate the mash adequately. I measured an original specific gravity of 1.077 temperature corrected for about 86 degrees. Then I placed in a fermentation chamber that I keep at a perfect 78 degrees. It may fluctuate from 76-82 degrees but my mash always measures about 77-78 degrees when I check temp. I also keep it in a 6.5G brew bucket with an airlock. SO... after 3 hours I checked the airlock and had no activity but I did not worry. I waited another 24 hours. Then I checked and there was no activity BUT I measured SG to be about 1.062 so I assumed all was well. After another 24 hours I measured SG at 1.060... that's when I began to worry. then after another 24 hours it STILL measured 1.060. So I reached out for some advice and after some consideration I decided to give it a good stir and repitch some rehydrated yeast (oh btw I use Red Star DADY). I got some action through the airlock after that (assuming I just released some trapped CO2) but after three more days I was only down to 1.055. Is my mash DONE? Wouldn't that only be about 2.9% yield? Was I being too hopeful to think I would have a final gravity of closer to 1.02? I read an article saying that maybe the malt wasn't enough to finish the sugar conversion and I should reheat the mash and add amylase enzyme then repitch again. What do you think?
×
×
  • Create New...